PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Problem mit WOL aus SuspendToRAM mit Gigabyte Barebone als Musikserver für Squeezebox Duet



boc
07.04.2009, 17:08
Hallo,
ich bin neu im Forum und versuche gerade, mir für meine Squeezebox Duet (1 Controller über WLAN, 2 Receiver am Ethernet) einen Musikserver einzurichten. Zunächst hatte ich einen QNAP TS109 II genutzt, lief auch gut, aber nicht optimal schnell. Beim "Eintauchen" in ein Album dauert es etwa 5 Sekunden bis man die einzelnen Titel sieht. Daher habe ich den QNAP wieder verkauft und mich für einen Gigabyte Barebone STC (1,5 Ghz, 1GB RAM, 320GB Platte) entschieden und UBUNTU 8.04 Desktop LTS installiert (Server war mir zu heftig als Linux Anfänger). Anschließend habe ich meine Musiksammlung aufgespielt und die Debian Version von Squeezecenter 7.3.2 installiert.
Ergebnis super: Scan von 15.000 Titeln in 39 min., ca. 7 mal schneller als der QNAP TS109 II (500MHz Prozessor und 256 MB RAM), Suchfunktion "Lazysearch" ist superschnell und Alben-browsen mit dem Duet Controller passiert quasi verzögerungslos.
So weit also alles super, 1. Teilprojekt abgehakt :-)......

2. Teilprojekt:
Wie bekomme ich den Gigabyte Barebone dazu, bei "Leerlauf" auf dem Netz zu den beiden Squeezeboxen in den SuspendToRam Modus zu gehen und bei Einschaltung des Duet Controllers wieder aufzuwachen? Hintergrund: Dauerbetrieb Server ca. 25 Watt, Ziel: im Supend To RAM ca. 3-6 Watt

a) Voraussetzungen:
- Gigabyte STC: gut! Integrierter Netztwerkchip von Realtek kann WOL (WakeOnLAN), Modi p,u,m,b,g. Mich interessiert g=wake up durch Magic Pakete
- Duet Controller: gut! sendet lt. Internet-Recherche bei Einschaltung Magic Pakete an die MAC Adresse des zuletzt aktiven Duet Receivers

b) Bios Einstellung für Suspend to RAM vorgenommen:
- ACPI enabled + Modus S3 (STR) SuspendToRAM
- Power on by PCI card enabled im Menü Powermanagement

c) Aktivitäten in Ubuntu
- Netztwerkchip wird mit Eintragung "ethtool -s eth0 wol g" in der Datei /etc/r.local bei Barebonestart auf den Modus g (wakeup durch Magic Pakete) eingestellt.
- Script aus Forum kopiert, welches den Netztverkehr mithorcht und 5minütlich prüft, wieviele Pakte an der Gigabyte Netzschnittstelle ankommen.
Script nach meinen Bedürfnissen angepaßt. => Läuft prima: Wenn der Duet Controller ausgeschaltet ist und beide Receiver im Normalmodus inaktiv sind, geht der
Barebone in Suspend to RAM.

Problem: Ich kriege den Barebone nicht mehr wach!!!

- Grund: Irgendetwas in Ubuntu setzt beim Übergang in den SuspendToRAM Modus den Netztwerkchip auf Modus d = "alle Modi deaktivieren, kein WOL möglich"
Festgestellt mit Befehl: ethtool eth0, Antwort WOL: d

==> Viel im Ubuntu WIKI gelesen http://wiki.ubuntuusers.de/Wake_on_LAN (http://wiki.ubuntuusers.de/Wake_on_LAN) und folgende Dinge ohne Erfolg probiert:
- halt script angepaßt "halt -d -f $poweroff $hddown" ( Prameter -i rausgenommen).
- pm-utils/sleep.d/50modules angepaßt, "unload network" Funktion auskommentiert.

in /proc/acpi/wakeup habe ich noch nichts gemacht, da meine Netzwerkkarte (pci gerät) nicht eingetragen war. Das hatte ich per Befehl: lspci mit Quecheck ermittelt.


==>

ethtool eth0 sagt immer noch "WOL: d", Gigabyte Barebone läßt sich daher nicht wecken


Hat jemand eine rettende Idee, was ich noch versuchen könnte?



BOC

huskyte
07.04.2009, 19:12
Hi boc,

das Verhalten ist bekannt. Im Grunde überschreibt das halt Deine Einstellung mit netdown=yes. Das ist uncool. Zudem könntest Du da auch noch die Konfiguration für WoL reinschreiben, danach sollte es persistent sein.

Genauer: http://wiki.ubuntuusers.de/Wake_on_LAN?redirect=WOL

Also, ich hoffe mal, dass das Problem ist...

boc
10.04.2009, 19:24
Hi Huskyte,

hatte ich versucht. Hat nichts gebracht.

Habe:
1. Habe im Bios ACPI ebabled und Power-on by PCI card
2. Habe /etc/init.d/halt geändert in "halt -d -f $poweroff $hddown"
3. habe /etc/default/acpi-support => stop services="networking" eingetragen.
4. Habe in rc.local => ethtool -s eth0 wol g eingetragen
5. Habe in usr/lib/pm-utils/sleep.d/50modules => unload network() auskommentiert
6. HAbe ein script, daß den rechner in S3 bringt, kriege ihn aber nicht wach, weil immer noch die Netztwerkkarte beim Übergang in suspend to ram durch irgend etwas abgeschaltet wird.

Ich glaube die pm-utils scripts sind es nicht, die werden der Reihe nach beim Suspend durchlaufen, aber da habe ich alles, was nach Netztwerk riecht, unwirksam gemacht.

Weiß jemand was nach den pm-utils scripts noch durchlaufen wird?

Gruß boc