PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Probleme beim Zugriff per Funambol auf eGroupWare



Firehand
19.05.2009, 08:52
Hallo Zusammen,

bin mal wieder bei meinem Ubuntu Server hängen geblieben. Ich habe auf Ubuntu 8.10 64bit Server eGroupWare installiert (v1.4) und danach auf Version 1.6 geuppdated. Zugriff funktionierte mit beiden Versionen problemlos.

Schwierigkeiten gibt es, wenn ich versuche, per SyncML Client Funambol (als Thunderbird Plugin) meine Daten mit eGroupWare zu synchronisieren. Dann erhalte ich immer die Fehlermeldung
HTTP Server Error: 500

Ich vermute dasss das Problem eher beim Apache zu suchen ist, ist aber schwer zu sagen. Das error log spuckt außer

PHP Fatal error: Call to undefined method PEAR_Error::authorize() in /usr/share/egroupware/rpc.php nichts aus.

sofern ich in der Apacheconfig bei <Location /egroupware/rpc.php>
das
php_admin_value mbstring.func_overload 0 rausnehme erhalte ich die Fehlermeldung
Error reading HTTP response from Server: received data of size = 0

Ich komm da grade echt mal überhaupt nicht mehr weiter. Zugriffe per GroupDAV funktionieren übrigens auch nicht.

ElektromAn
19.05.2009, 12:34
Hallo,

die Meldung




PHP Fatal error: Call to undefined method PEAR_Error::authorize() in /usr/share/egroupware/rpc.php

sagt eigentlich ja schon (fast) alles

Installiere mal eine neue Verison von PEAR-Auth.

ggf. ist auch ein Update der PEAR Funktionen nötig.

Für GroupDav, hast du WebDav in Apache aktiviert, bzw. als Modul eingebunden ??

E-mAn

Firehand
19.05.2009, 14:20
Ja, WebDAV ist eingebunden.
PEAR sollte eigentlich kein Problem darstellen, hab mir schon die aktuellste Version besorgt.

ElektromAn
19.05.2009, 15:39
Dann frage mal deine Paketverwaltung welche Module eGroupWare braucht.
Wenn eGroupWare "per Hand" in Ubuntu installiert wurde, prüfe mal die Pfade der enzelnen Module.
LSB (Linux Standard Base) ist schön, aber es müssen sich nicht alle dran halten.

Firehand
19.05.2009, 16:10
Mach ich wenn ich daheim bin. Ich hab mir auch mal noch eine leicht modifizierte egroupware.conf für Apache gezogen. Mal schauen was dabei rauskommt.

ElektromAn
19.05.2009, 20:58
Dann grep auch mal nach der fehlenden Funktion

AndreasMeier
16.06.2009, 17:24
Ist Dein Problem jetzt gelöst oder noch nicht?

Bei mir läuft eGW 1.6.
Weißt Du, ob man irgendwo eine ordentliche Feldzuordnung (welches Feld wird in welches Feld geschrieben) vornehmen kann?

Gruß
Andreas

Firehand
17.06.2009, 09:55
Nein, Problem besteht weiterhin. Habs jetzt etwas nach hinten geschoben, da ich grade nicht so dazu komme. Aber der Fehler ist nach wie vor der gleiche.

AndreasMeier
17.06.2009, 10:17
Wenns Sinn macht, können wir installierte Pakete abgleichen.
Bei mir läuft Debian Etch auf dem Server, zusammen mit PHP5 und PEAR etc.
Dein Ubuntu ist ja Debian sehr ähnlich.
Meld Dich bei Interesse.

Firehand
17.06.2009, 10:58
Gerne :)

Muss allerdings schauen, wie ich die nächsten Woche dazu komme.

Firehand
25.06.2009, 19:10
So, hier hab ich jetzt mal nochmal den Auszug aus einem aktuellen Debug:



19:05:52 GMT +1:00 [DEBUG] - Connecting to 10.8.0.1:80
19:05:52 GMT +1:00 [DEBUG] - Requesting resource /egroupware/rpc.php
19:05:53 GMT +1:00 [DEBUG] - Message sent
19:05:53 GMT +1:00 [DEBUG] - HTTP server error: 500. Server failure.
19:05:53 GMT +1:00 [ERROR] - Error in preparing sync: HTTP server error: 500. Server failure.
19:05:53 GMT +1:00 [DEBUG] - ================================================== =========
================ SYNCHRONIZATION REPORT ===============
================================================== =========
Last error code = 2052
Last error msg = HTTP server error: 500. Server failure.


Ich kanns mir weiterhin nicht erklären....
Läuft eigentlich bei irgendjemand die eGroupWare-Sync per Funambol?

AndreasMeier
26.06.2009, 14:28
Also bei mir läuft folgendes:
1.) Client mit KDEPim agiert direkt mit eGW über xmlrpc, allerdings hakt es da manchmal.
2.) Client mit Outlook und Funambol sync zu eGW. Geht, aber Probleme wegen mangelhafter Feldzuordnung, siehe unten.
3.) Sync eines Nokia E-Series-Handys (im Moment noch ein E61i) per Funambol und WLAN.
Geht theoretisch, praktisch nur kurz an einer anderen Installation getestet, noch kein Produktivbetrieb, da ich WLAN nur an Standort A, eGW aber an Standort B ohne WLAN habe, und der Zugriff auf eGW übers Internet noch nicht ausreichend abgesichert und somit auch noch nicht von außen freigegeben ist. Sonst hätte ich hier mal richtig testen können. Und auch hier Probleme mit der Feldzuordnung.

Generell finde ich ziemlich ätzend, dass es keine gescheite Feldzuordnung bei den verschiedenen Sync-Wegen gibt.
Dadurch wird manches echt unnütz, Beispiel ist das Ende-Datum bei Wiederholungen, welches nicht ins richtige Feld "übersetzt" wird.

So, wenn Du mir sagst, wie ich Dir helfen kann, dann gerne.
Läuft Funambol über die egroupware/rpc.php, oder auch über die xmlrpc.php?
Serverfehler 500 hat irgendwas mit CGI-Skripten zu tun.

Gruß
Andreas

Firehand
28.06.2009, 09:15
Ich synce mit Funambol auf die egroupware/rpc.php. Mit xmlrpc hab ich da noch nie probiert. Wäre das dann egroupware/xmlrpc.php?

Das mit den cgi's hatte ich vermutet. Mal sehen, ob ich da noch schlauer werde ;)

AndreasMeier
29.06.2009, 07:40
Wäre das dann egroupware/xmlrpc.php?
Ja, korrekt.
Von welchem Client (auch Programm) aus willst Du denn syncen?
Bei Funambol denk ich, dass das Win/Outlook sein wird.

Die xmlrpc.php nutz ich aber in meiner Linux/KDEPim-Konstellation, d.h. KDEPim direkt auf die xmlrpc.php ohne Funambol.
Und: Meines Erachtens musste ich aber bei meiner Win/Outlook-Konstellation bei Funambol nicht großartig einstellen, wohin er syncen soll, müßte direkt nochmal nachschauen.

Update: stimmt nicht, beim Outlook-Funambol geht das ganze auf egroupware/rpc.php, so wie bei Dir!

HeinrichLoose
12.08.2009, 16:47
Hier ein Lösungsweg, der unter Debian 5.0 Testing funktioniert:

/etc/apt/sources.list auf Testing stellen
und egroupware 1.6.002 installieren (Stand: 12.08.2009)

Nochmal alle Pakete: apt-get install egroupware mysql-server php5-mysql libapache2-mod-fcgid

Ganz wichtig ist das libapache2-mod-fcgid

Folgende Timeouts und Abbrüche treten bei großen Sync-Vorgängen auf:
cgi bricht ab (error 500 nach 20 Sekunden)
apache bricht den Post-Request ab (nach 5 Minuten)
PHP hat keinen Speicher mehr (32MB in der Default-Einstellung)

Um das zu lösen, müssen folgende Änderungen durchgeführt werden:

/etc/apache2/apache2.conf :
TimeOut 1200

/etc/apache2/mods-enabled/fcgid.conf :

<IfModule mod_fcgid.c>
AddHandler fcgid-script .fcgi .fcg .fpl
IPCConnectTimeout 1200
IPCCommTimeout 1200
</IfModule>

/etc/apache2/conf.d/egroupware :
php_value memory_limit 96M

Danach noch ein /etc/init.d/apache2 restart und es sollte gehen.

Vermutlich ist es sinnvoll, die Werte wieder zu reduzieren, wenn die großen Adressbücher und Kalender nach dem Initial-Sync erstmal in der DB sind.

Als Connector sollte man den Funambol 7.0.7 für Outlook verwenden, da ab Version 7.1 das SIF-Format nicht mehr unterstützt wird und somit Telefonnummern und eMail-Adressen nicht übertragen werden.

Alte Versionen gibt es hier:
http://forge.ow2.org/project/showfiles.php?group_id=96

Gruß
H.

AndreasMeier
17.08.2009, 11:21
Ja, wie geil ist das denn!

Coole Hinweise, die Du hier postest !
Herzlichen Dank, werd mich gleich mal dran machen und ausprobieren.

Hast Du das neben Funambol für Outlook noch mit anderen Clients ausprobiert?
KDE4?

Gruß
Andreas

HeinrichLoose
17.08.2009, 12:31
Hallo Andreas,

folgende Clients verwenden wir hier im Produktiveinsatz:

syncevolution unter Ubuntu 9.04

Nokia E71 Handy über Syncml + WLAN

KDE4 habe ich noch nicht getestet, sollte aber über Groupdav kein Problem sein.

Viele Grüße
H.

AndreasMeier
21.08.2009, 07:50
Hallo Heinrich,

geht euer Nokia-Sync auch, wenn der Webzugriff auf eGW durch eine htaccess-Passwortabfrage geschützt ist ?
Oder synct ihr nur innerhalb des LANs ?

Danke und Gruß
Andreas

HeinrichLoose
21.08.2009, 12:26
Hallo Andreas,

unser Server ist öffentlich zugänglich und wird nur durch die Anmeldung an eGW geschützt. Ich ging bis jetzt immer davon aus, dass eGW keine Sicherheitslöcher hat, die man mit einer weiteren htaccess stopfen muss. Hast Du da andere Erfahrungen? Würde mich sehr interessieren.

Was aber gehen sollte, wenn man eine htaccess zusätzlich einsetzen will:

Serveradresse: http://username:password@serveradresse/egroupware/rpc.php

Viele Grüße
H.