Ergebnis 1 bis 8 von 8

Thema: Externer Zugriff auf FTP und WEB Dienste

  1. #1

    Standard Externer Zugriff auf FTP und WEB Dienste

    einen schönen guten morgen.

    nachdem mein eusso meine daten mit hingabe zerstört hat, hab ich es gegen ein qnap 409 Pro getauscht.
    gleich vorweg. ich bin begeistert von dem teil. vorallem die performance und die weboberfläche gefällt mir sehr gut. und ein paar "unglückliche" übersetzungen erheitern zwischendurch die verwaltung. aber es bleibt nichts im unklaren.

    leider hab ich 3 kleine probleme, die trotz vielem herumprobieren nicht gelöst werden konnen
    von außen komm ich nicht auf den ftp- und webserver. und ein fopen von einem php skript geht auch nicht.
    ein forwarding am router ist natürlich vorhanden. das hat auch mit dem vorigen und vorvorigen nas funktioniert. der ftp- und webzugriff.
    der ftp-client bekommt die meldung, dass eine verbindung hergestellt wurde, und er auf die willkommensnachricht wartet. auf diese wartet er aber vergeblich. im lan funktioniert der zugriff auf beide dienst.
    dann noch das fopen problem. es schaut so aus, als würde die box den zugriff nach draußen unterbinden. in der php.ini ist der schalter "allow_url_fopen" auf on (heißt so, oder so ähnlich, hab aber nachgeschaut).
    die neueste firmware hab ich oben.
    vielleicht hat ja jemand einen tip für mich.

    ps.: was auch nicht funktioniert ist, der update über den ddns. vielleicht als hinweis.
    Mein NAS
    QNAP 419 PRO TURBO NAS. RAID 5. 3TB

  2. #2

    Standard

    einen fehler am router kann ich ausschließen. ich hab eine ip-kamera auf einem anderen port als 80 laufen. auf die komm ich von außen drauf. also daran kann es eigentlich nicht liegen.
    Mein NAS
    QNAP 419 PRO TURBO NAS. RAID 5. 3TB

  3. #3

    Standard

    Na denn: willkommen bei den qnappern!

    Zum FTP-Problem: Du musst noch die passiven ports im router öffnen (die port nummer sind im web-if angegeben, bzw. kannst du sie dort definieren). Aus Sicherheitsgründen verwende bitte FTP über SSL (FTPES. filezilla kann das zum Beispiel).

    was meinst du mit webserver? das web-interface? von aussen würde ich das nur über https machen, dazu den port 443 im router an das NAS weiterleiten und dann mit https://deine.dyndns.adresse einloggen.

    der ddns update dienst sollte sowieso auf dem router laufen.

    vielleicht interessant für dich. Über VPN hast du remote einen kompletten zugriff auf alle services, so als ob du zuhause wärst.
    mfg,
    vishcompany

    Newbie-FAQ - Linux für Anfänger - forumregeln - Leitfaden
    for our international users: language settings - posting guide - translation service

    Verwechsle niemals Redundanz (RAID1) mit Datensicherheit (backup)!

    Bitte keine supportanfragen per PM. Support gehört ins Forum, dann haben alle etwas davon!

  4. #4

    Standard

    danke fürs willkommen

    meinst du mit freigen der ports eine weiterleitung oder was anderes? bis jetzt hab ich nur probiert, dese prots (größer als 5000 - weiß sie jetzt nicht auswendig) wieter zu leiten. der linksys router (aha, jetzt wissen wir welchen router ich einsetze ) hat noch eine andere möglichkeit der port-verwaltung. werde mir das anschauen, sobald ich wieder zu hause bin. sftp ist sicher eine bessere möglichkeit. auch das werde ich austesten.

    bezüglich web. nein, ich meine nicht den zugriff auf die verwaltungsoberfläche. das möchte ich auch gar nicht. die soll nur im lan laufen. ich meine den webzugriff über den port 80. die box bietet ja die möglichkeit eine homepage zu hosten. will ich jetzt zwar grundsätzlich nicht, aber ich hab hin und wieder ein paar ideen, die ich gerne vorher auf der box teste und auch anderen presentieren will. und da ist es halt notwendig, von außen auf die box über port 80 drauf zu kommen.
    ich werde das alles probieren und testen. schau ma mal was dabei rauskommt. weil grundsätzlich sollte es ja funktionieren. so stehts in den spezifikationen.
    Mein NAS
    QNAP 419 PRO TURBO NAS. RAID 5. 3TB

  5. #5

    Standard

    hilft alles leider nichts. ich hab mal bildschirmkopien von meinen einstellungen am router und am nas gemacht.
    bin etwas ratlos.
    Angehängte Grafiken Angehängte Grafiken
    Mein NAS
    QNAP 419 PRO TURBO NAS. RAID 5. 3TB

  6. #6

    Standard

    Die Einstellungen sehen alle korrekt aus (port triggering habe ich hier nicht eingestellt, weil es auch ohne geht).
    Ich kann jetzt nicht sehen, warum das nicht funktionieren sollte.

    Ev. mal den router und das NAS rebooten?
    mfg,
    vishcompany

    Newbie-FAQ - Linux für Anfänger - forumregeln - Leitfaden
    for our international users: language settings - posting guide - translation service

    Verwechsle niemals Redundanz (RAID1) mit Datensicherheit (backup)!

    Bitte keine supportanfragen per PM. Support gehört ins Forum, dann haben alle etwas davon!

  7. #7

    Standard

    Zitat Zitat von vishcompany Beitrag anzeigen
    Die Einstellungen sehen alle korrekt aus (port triggering habe ich hier nicht eingestellt, weil es auch ohne geht).
    Ich kann jetzt nicht sehen, warum das nicht funktionieren sollte.

    Ev. mal den router und das NAS rebooten?
    das triggering war nur so zum probieren. einfach nichts auslassen. nas und router wurden schon mehrmals neu gestartet.
    aber denke fürs kontrollieren.
    laut einem portscanner sollten die ports 21 und 80 auch offen sein. hm. jetzt wäre interessant, ob es eine möglichkeit gibt, "mit zu lesen", was der router macht, wenn eine anfrage auf 21 kommt. oder sich irgendwie zwischen die beiden hängen. obs am router liegt, oder am nas.
    ich bin mir nicht mehr SO sicher, obs am nas liegt. wobei die weiterleitung des prots 1024 einwandfrei funktioniert.
    Mein NAS
    QNAP 419 PRO TURBO NAS. RAID 5. 3TB

  8. #8

    Standard


    es geht. mein gott. welch ein fehler. das nas hat ja eine gateway einstellung. nona. braucht sie ja. ich hab fast alles richtig eingegeben. nur beim ersten segment hab ich mich vertippt. 169 statt 192.
    tja. jetzt geht alles. mail, dyndns (läuft eh am router ), ftp und web. und das fopen
    danke fürs kopf zerbrechen.
    und wie bin ich draufgekommen?
    bei der übersicht der netzwerkeinstellung ist beim gateway immer 0.0.0.0 gestanden. ich hab nachgeschaut. der wert war für mich richtig. war er aber nicht
    Mein NAS
    QNAP 419 PRO TURBO NAS. RAID 5. 3TB

Ähnliche Themen

  1. NAS Zugriff über Web
    Von asomy im Forum Kaufempfehlungen
    Antworten: 0
    Letzter Beitrag: 28.10.2008, 11:09
  2. Externer FTP Zugriff auf ein NAS-System mit "einem/zwei" Routern
    Von speedport701 im Forum Wiki Diskussionsbereich
    Antworten: 0
    Letzter Beitrag: 08.09.2008, 03:16
  3. IB-NAS4220-B FTP-Zugriff lokal und extern
    Von OXI im Forum Packages, Tools und Erweiterungen
    Antworten: 13
    Letzter Beitrag: 13.02.2008, 09:55

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •