Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 22

Thema: FTP Download via Internet

  1. #11

    Standard

    Hallo,

    ich ahbe auch das Problem, dass meine Übertragungsgeschwindigkeit nach aussen 4kb/s beträgt. Habe auch schon mit den MTU-Werten rumexperementiert. => kein Erfolg !

    Hat jemand inzwischen eine Lösung?
    Was waren die Schritte, die zum Erfolg führten?

    Danke im voraus
    IB-4220-B
    1 x Seagate Barracuda 7200.11 500 GB 32MB Cache

  2. #12

    Standard proftpd.conf editieren

    hey leutz!

    ich hatte auch seit beginn an geanu das problem, dass über interne ftp zugriffe wunderbar 10mbit/s up/down, doch via internet ftp kamen im down nur 3-7kb/s zustanden, aber weiterhin der voller up des gegenüber.

    nun habe ich heute den ganzen tag damit verbracht meine proftpd.conf zu editieren, um eigentlich nur die loginzugriffe ein bisschen einzuschränken und mein nas-4220 so einzurichten, dass nach einem reboot die einstellungen nicht wieder wech sind!

    als grundlage habe ich eine Konfigurationsbeispieldatei vom ersteller des tools zum erstellen von userscripts genommen.
    hier zum downloaden: http://forum.nas-portal.org/showthre...=5450#post5450

    darin enthalten waren die markierten zusätzlichen codezeilen:

    ServerName "NAS FTPD"
    ServerType standalone
    DefaultServer on
    DefaultRoot /mnt

    CharsetLocal UTF-8
    CharsetRemote CP1252

    SystemLog /var/log/messages
    Port 21
    Umask 006
    MaxInstances 30

    User nobody
    Group nobody

    RequireValidShell off

    #### userscript - mod
    # Tuning settings
    IdentLookups off
    UseReverseDNS off
    WtmpLog off
    ListOptions "-l"
    DenyFilter \*.*/
    ####



    receivefile on ## This parameter is for TSS. You can fill in either "on" or "off". ##

    ScoreboardFile /var/run/proftpd.pid

    # Normally, we want files to be overwriteable.
    <Directory /*>
    AllowOverwrite on
    </Directory>

    #### userscript - mod
    # Downloadresume
    <global>
    AllowOverwrite on
    AllowRetrieveRestart on
    AllowStoreRestart on
    </global>
    ####


    <Directory /mnt/ide1/lost+found>
    HideNoAccess on
    <Limit ALL>
    DenyAll
    </Limit>
    </Directory>
    <Directory /mnt/ide1/admin>
    <Limit DIRS READ WRITE>
    DenyAll
    </Limit>
    <Limit DIRS READ WRITE>
    AllowUser admin
    </Limit>
    </Directory>
    naja und siehe da nun habe ich meine proftpd.conf komplett umgeschrieben und mit den neuen funktionen mein nas rebootet und ich hab nun meinen vollen down und up!!!

    zudem funzt das login via browser in ftp nun auch viel schneller!

    ich gehe mal stark davon aus dass die zeilen für die tuning settings die ursache dafür sind, dass endlich die leitung voll genutzt wird!

    probierts aus!

    wer evtl. noch fragen hat wo sich die zu proftpd.conf befindet und wie man sie richtig editiert und vermeidet, dass die settings nach einem reboot wieder überschrieben werden, kann hier nachlesen, oder frag mich einfach selbst kurz, jetzt weiß ich ja wie es geht!

    http://forum.nas-portal.org/showthread.php?t=919
    http://de.nas-4220.org/index.php?tit...ges:userscript

    lg hope could help

  3. #13

    Standard

    Die Tuningeinstellungen waren wirklich nur für einen schnelleren Login und dem Downloadresume gedacht. mit dem Speed ins internet hatten die sachen nix zu tun, da der Proftp keinen Unterschied macht. Aber trotzdem schön wenn es bei dir funktioniert.
    NAS: IB-NAS4220-B
    HDD: 2x 500GB WD5000AAKS 16mb JBOD
    LAN: D-Link 8Port Gigabitswitch
    Ver.: 2.6.0.IB.1.RS.1 inkl. ssh-Paket; userscriptV2; local_app; mc; Webserver; Twonky;

  4. #14

    Standard Habe auf nem anderen Forum noch Infos zum problem gefunden

    Tach zusammen,

    hier ne kurze Zusammenfassung des Problems aus dem Forum

    "h p://forum.nas-forum.org/thread.php?threadid=30"

    Folgende neue Erkenntnisse:
    ftp im ascii mode - schnell
    ftp im bin mode - langsam

    Hab' mit wireshark traces gemacht:
    ascii - TCP Datenpaketgröße 1440 bytes / bin - 1448 bytes!

    Bei ascii läuft das Protokoll glatt ab, aber bei bin kommt nach dem ersten Paket "Fragmentation needed" von der Gegenstelle.
    Es kommen immer 2 große (1448 bytes) und ein kleineres (1200) Paket, welches durchkommt.
    Dadurch kommt es natürlich zu "Retransmits" und die Übertragung wird langsam.

    Es scheint also im ftp bin mode das TCP Datenpaket zu groß zu werden und geht dann nicht über das ADSL Modem, weil dort nur MTU=1492 statt 1500 wie im lokalen Netz erlaubt ist.

    Mir ist es leider nicht gelungen durch die MTU Einstellung die Paketgröße zu verändern.

    Vielleicht kann das jemand von euch bestättgen.

    Also: Prob aus Sicht der Leute vom anderen Forum:

    Ändern der MTU auch für Binary Mode auf 1440 und das speicherresistent, dann sollte das Problem gelöst sein. (Besser 1400?? 1440 würde bei mir nicht gehen)
    Wie mache ich das? Jemand nen Plan?
    (ich geh von nat-Client übder Router über Modem in WAN über Modem über Router auf NAS, ich schaffe mit ping -f -l max 1420..., deshalb)

    Grüsse

    Chris aus München
    Geändert von mindmachine (22.11.2009 um 20:24 Uhr) Grund: Link auf neues Forum aktualisiert...

  5. #15

    Standard

    Zitat Zitat von mindmachine Beitrag anzeigen
    Ändern der MTU auch für Binary Mode auf 1440 und das speicherresistent, dann sollte das Problem gelöst sein. (Besser 1400?? 1440 würde bei mir nicht gehen)
    Wie mache ich das? Jemand nen Plan?
    Code:
    ifconfig eth0 mtu 1440
    Am einfachsten das MTU-Skript von Raidsonic ziehen und die enthaltene MTU.conf entsprechend anpassen - einfach statt der 1492 1440 oder was auch immer eintragen.

    Bitte bei Erfolg kurzen Wiki-Eintrag verfassen, was genau gemacht wurde. Danke (im Namen aller)

    gruss
    skara
    Ob jemand das Wiki oder die Suche benutzt hat, merkt man an den Fragen.
    Ob die Lösung dort drin steht, merkt man an den Antworten (3501051808)


    Fragen nach sinnvollen Begriffen zum Suchen werden immer beantwortet. Um alles vorgekaut zu bekommen teile ich aber auf Anfrage gerne meinen Stundensatz mit!

  6. #16

    Standard ifconfig....

    meines Wissens nach ist das nicht speicherresistent und wird wieder überschrieben.
    Es wurden gemäß eines Threads im nas2000 Forum hier schon ausgiebig herumprobiert und es gab kein vernünfitges Ergebnis.

    MRT hat aber inzwischen eine neue Firmware auf der Homepage mit der lt. MRT das Problem gelöst ist.
    Zitat Mail:
    Please download firmware from ftp.syncquick.com.
    User ID: guest
    Password: mrt1234

    File name: /35HD-DUAL-NAS/Firmware/G5S50033B30_DUAL-NAS.exe

    Firmware G5S50033B30 release notes - 2008/02/25

    Modification:

    1. Revises RAID1 to be unable the Rebuilding question

    2. Revised FTP to download the slow question


    Programmieren kann man sich dann wohl sparen. Leider habe ich beim modifizieren über jtag-adapter meine Katz ins Zimmer gelassen (Bier holen gegangen, Tür offen gelassen...). Die hat dann am Lötkolben gerochen, was keine schlaue Idee war. Noch dümmer war, dass sie vor Schreck meinen Versuchsaufbau vom Tisch gefegt hat. War mitten im Flashen (brauch ja immer was Zeit, leider). Hat dem Nas nciht gutgetan..... gar nicht gutgetan... (Heul!)
    Geändert von mindmachine (02.03.2008 um 00:46 Uhr)

  7. #17

    Standard

    Das MRT-Pendant zum NAS4220 ist aber Dual-NAS-E !!! Auf dem Server existiert neben dem "35HD-DUAL-NAS" auch ein "35HD-DUAL-NAS-E-irgendwas".
    Hat schon jemand mal eine MRT-Firmware aufgespielt und zurück zur RS? Funktioniert's oder NAS geschrottet?

    gruss
    skara
    Ob jemand das Wiki oder die Suche benutzt hat, merkt man an den Fragen.
    Ob die Lösung dort drin steht, merkt man an den Antworten (3501051808)


    Fragen nach sinnvollen Begriffen zum Suchen werden immer beantwortet. Um alles vorgekaut zu bekommen teile ich aber auf Anfrage gerne meinen Stundensatz mit!

  8. #18

    Standard

    Hat schon jemand mal eine MRT-Firmware aufgespielt und zurück zur RS? Funktioniert's oder NAS geschrottet?
    Ich hab die neue Firmware von MRT aufgespielt allerdings nicht zurück.

    MRT Support spricht mit gespaltener Zunge, das FTP Problem ist beileibe nicht gelöst!!

    Die ifconfig Methode habe ich auch probiert, man bekommt zwar dann den Wert 1400 oder was auch immer ausgelesen, auch speicherresistent, allerdings ändert das nichts an der Upload (bzw. von aussen download)-Rate von ärmlichen 5 KB/s....
    Hab ewig rumprobiert und jetzt keine Lust mehr

    Ich habe auch bisher in keinem anderen Forum einen Lösungsansatz gefunden, wenn jemand was weiss, immer her mit der Lösung!


    Grüsse
    mindmachine

  9. #19

    Standard Reboot ????

    hallo an alle
    ich habe ein 35HD-DUAL-NAS-E mit gleichen problem habe aber uplads gelost mit mtu won 1426 (strato proweider) und mein proftpd.conf sieht so auss:

    ServerName "NAS FTPD"
    ServerType standalone
    DefaultServer on
    DefaultRoot /mnt

    CharsetLocal UTF-8
    CharsetRemote CP1250

    SystemLog /var/log/messages
    Port 21
    Umask 006
    MaxInstances 30

    ####
    #
    MasqueradeAddress xxxxxx.dynalias.com
    PassivePorts 60000 60100

    <IfModule mod_delay.c>
    DelayEngine off
    </IfModule>

    UseSendfile off
    ####

    User nobody
    Group nobody

    RequireValidShell off

    ####
    #
    IdentLookups off
    UseReverseDNS off
    WtmpLog off
    ListOptions "-l"
    DenyFilter \*.*/
    ####

    receivefile on ## This parameter is for TSS. You can fill in either "on" or "off". ##

    ScoreboardFile /var/run/proftpd.pid

    # Normally, we want files to be overwriteable.
    <Directory /*>
    AllowOverwrite on
    </Directory>

    ####
    #
    <global>
    AllowOverwrite on
    AllowRetrieveRestart on
    AllowStoreRestart on
    </global>
    ####
    mir fehlt nur dass dass nach reboot bleibt erhalten kome mit den script aus forum nicht zu recht wird nicht ausgefhurt benutze orginal firmware won mrt.....
    bis dan...


  10. #20

    Standard

    Hallo liebe NAS Kollegen!

    Wir haben fürs NAS2000 eine Lösung für das Probem "langsamer ftp upload" gefunden. Könnte bei euch auch passen.
    Es gibt auch ein Paket "do_it" für die dauerhafte proftpd Konfiguration.

    Viele Grüße aus dem NAS2000 Forum,
    HWguru
    Geändert von HWguru (12.11.2009 um 02:21 Uhr) Grund: Link aktualisiert

Ähnliche Themen

  1. IB-NAS4220-B HTTP Download Client
    Von streusel im Forum Packages, Tools und Erweiterungen
    Antworten: 27
    Letzter Beitrag: 02.02.2008, 00:35

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •