Ankündigung

Einklappen
Keine Ankündigung bisher.

Datenrettung von einzelner Platte?

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • 35HD-DUAL-NAS-E Datenrettung von einzelner Platte?

    Moin!

    Habe mich hier angemeldet, weil ich Hilfe benötige mit meinem NAS-Gerät. Ich denke, es ist ein MRT 35HD-DUAL-NAS(-E?), jedenfalls dem Bild z.B. hier nach. Ich habe es mal unter dem Namen "Dual Bay GigaNas" gekauft, da lag aber keine Doku dabei, die auf einen genaueren Typ schließen ließ.

    Ich benutze das Gerät nun schon eine Weile, und da mir der Datendurchsatz nicht ganz so gefallen hat, und ich auch nach nun knapp zwei Jahren auch sicherheitshalber neue Festplatten haben wollte, war also die Ablösung schon beschlossen. Das hat das Gerät wohl mitbekommen...

    Das Netgear-Gerät ist also nun da, konfiguriert, und ich bin am Daten-Schaufeln. Seit gestern nun habe ich Probleme bekommen:

    Die Datenübertragung ist extrem langsam geworden. Maximal laufen noch 100 kB/s über die Leitung -und ich habe noch gut 80GB vor mir. Ein Blick ins WI brachte den "Disk occur wrong"-Fehler hervor. Also ein wenig gegoogled, und dann die Diagnose angefangen.

    cat /proc/mdstat ergab folgendes:
    Code:
    nas> cat /proc/mdstat
    Personalities : [linear] [raid0] [raid1] [raid5] [multipath] [raid10]
    md1 : active raid1 hdc2[0]
          976398464 blocks [2/1] [U_]
    
    
    md0 : active raid1 hdc1[0]
          104320 blocks [2/1] [U_]
    
    
    unused devices: <none>
    Ok, da fehlt hdd. Also:

    Code:
    nas> mdadm --add /dev/md0 /dev/hdd1
    mdadm: re-added /dev/hdd1
    nas> cat /proc/mdstat
    Personalities : [linear] [raid0] [raid1] [raid5] [multipath] [raid10]
    md1 : active raid1 hdc2[0]
          976398464 blocks [2/1] [U_]
    
    
    md0 : active raid1 hdd1[1] hdc1[0]
          104320 blocks [2/2] [UU]
    
    
    unused devices: <none>
    nas> mdadm --add /dev/md1 /dev/hdd2
    mdadm: re-added /dev/hdd2
    nas> cat /proc/mdstat
    Personalities : [linear] [raid0] [raid1] [raid5] [multipath] [raid10]
    md1 : active raid1 hdd2[2] hdc2[0]
          976398464 blocks [2/1] [U_]
          [>....................]  recovery =  0.0% (7744/976398464) finish=4172.6min speed=3872K/sec
    
    
    md0 : active raid1 hdd1[1] hdc1[0]
          104320 blocks [2/2] [UU]
    
    
    unused devices: <none>
    Aktuell schätzt mdstat noch gut 12 Stunden.

    Falls das Recovery des RAID fehlschlägt, und dem Gerät traue ich nicht mehr wirklich - kann ich die derzeit noch mit Daten bepackte und (noch halbwegs) funktionstüchtige Platte an einem (Linux-)Rechner direkt mounten auch ohne RAID, und dann so die Daten retten?

    Ich bin grad schon etwas panisch ob der Daten, die ich definitiv nicht verlieren darf. Ich hatte ja schon vermutet, dass da so langsam mal eine Platte aufgeben könnte, und ging davon aus, dass die Spiegelung dann ja das Schlimmste verhindern würde. Dass es bei den Geräten dieses Problem mit Samsung-Platten gibt war mir nicht bekannt - übel dass es so verkauft wurde. Habe es einfach aufgebaut und benutzt. Trügerische Sicherheit...

    Also, nun 12 Stunden Nägelknabbern oder gibt es begründete Hoffnung?
    ---
    MRT 35HD-DUAL-NAS-E (vermutlich)
    Firmware G5S604110026302
    2 x 1TB Samsung HD103SI

  • #2
    Code:
    nas> cat /proc/mdstatPersonalities : [linear] [raid0] [raid1] [raid5] [multipath] [raid10]
    md1 : active raid1 hdd2[1] hdc2[0]
          976398464 blocks [2/2] [UU]
    
    
    md0 : active raid1 hdd1[1] hdc1[0]
          104320 blocks [2/2] [UU]
    
    
    unused devices: <none>
    So, scheint durch zu sein. Muss ich das Gerät nun neu starten, um zu sehen ob es funktioniert hat? Der Kopiervorgang ist jedenfalls noch nicht schneller geworden...
    ---
    MRT 35HD-DUAL-NAS-E (vermutlich)
    Firmware G5S604110026302
    2 x 1TB Samsung HD103SI

    Kommentar


    • #3
      Kopieren abgebrochen, neugestartet - das Raid existiert noch, auch das WI sagt nun es wäre alles OK.

      Die Datenübertragung kriecht allerdings wieder mit knappen 100kB/s - was kann das nun noch sein? Ich habe nicht die Möglichkeit, ~10 Tage lang rund um die Uhr zu kopieren...
      ---
      MRT 35HD-DUAL-NAS-E (vermutlich)
      Firmware G5S604110026302
      2 x 1TB Samsung HD103SI

      Kommentar


      • #4
        Du kannst auch die Platte ausbauen und ein einem Rechner mit einem Live Linux anschliessen.

        Die Partition ist ein "normales" ext2 oder ext3.

        ggf. musst du den mount Befehl überreden.
        Some random kernel coder
        Lots of stuff attached to serial console
        https://github.com/ulli-kroll

        Kommentar


        • #5
          Mittlerweile sind die Daten gesichert, lange gedauert hat es aber dennoch.

          Ich hatte das NAS noch getestet mit jeweils nur einer der Festplatten - die Geschwindigkeit blieb bei 90-110kB/s. Ich denke, da sind nicht unbedingt die Platte dran Schuld. Habe dann eine der Platten in einen Windows 2003 Server gebaut und per Ext2FSD angebunden. Dann war ein Kopieren mit ordentlicher Geschwindigkeit möglich. Allerdings musste ich häppchenweise kopieren, da es nach einigen zig GB zu Ressourcenengpässen kam und der TotalCommander (verwendet weil er weiterkopieren kann, wenn Lesefehler auftreten) dann ausstieg.

          Fazit: Daten in Sicherheit, altes NAS zunächst eingemottet, schaue ich mir irgendwann mal genauer an, ob es sich mit Firmwareaktualisierung und frisch formatierten Platten wieder zur Diensttauglichkeit bewegen lässt.
          ---
          MRT 35HD-DUAL-NAS-E (vermutlich)
          Firmware G5S604110026302
          2 x 1TB Samsung HD103SI

          Kommentar

          Lädt...
          X