Ankündigung

Einklappen
Keine Ankündigung bisher.

Raid wiederherstellen über 2x USB-SATA Konverter?

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • IB-NAS4220-B Raid wiederherstellen über 2x USB-SATA Konverter?

    Hallo

    abenteuerliche Frage:

    ist es möglich ein Raid unter Knoppix wiederherzustellen unter Verwendung zweier USB zu SATA Konvertern wie diesem hier zB.
    Konverter

    oder eher so eine Raid Controller Karte:
    Controller

    mfg
    Monorail
    Zuletzt geändert von Monorail; 23.09.2008, 12:51.
    NAS:
    Product Name: IB-NAS4220-B
    Firmware Version: 2.6.3.IB.1.RS.1
    MlDonkey Version: 2.9.5 (derzeit nicht wegen Problemen)
    Userscript (derzeit nicht wegen Problemen)
    HDD: 2 x Seagate 500 GB Barracuda 7200.11 (derzeit im ****)
    Raid level: RAID 0 (schlechte Wahl wie ich feststellen musste)
    Mein Problem: THREAD
    Router:
    Product Name: Linksys WRV200 mit VPN
    Firmware Version: 1.0.39

  • #2
    Grundsätzlich: vielleicht.

    Voraussetzung 1: die Erkennung der RAID-Header in der Partitionstabelle funktioniert.
    Voraussetzung 2: das RAID ist ebenfalls als Software-RAID unter Linux mit einer ähnlichen Version des Kernels erstellt worden.

    Dann kann es funktionieren.

    Kommentar


    • #3
      Hallo

      Da es hier Primär um die ICXBOX geht :
      USB nach SATA funktioniert, oder auch jeder andere SATA Anschluß soweit kein RAID mit drin ist.
      Mit RAID meine ich hier Hardware, ist meist zu erkennen am eigenen BIOS. Da deren Funktion nicht "offen" ist, und zum Teil nicht von älteren Kerneln unterstützt wird.
      Die 4220B und CH3NAS haben beide Linux-Software RAID

      Bei nutzen von USB nach SATA sollten die Platten beim booten vorhanden sein, damit der Autorun funktioniert. Sonst kann einfach mit mdadm nachgeholfen werden.


      E-mAn
      Some random kernel coder
      Lots of stuff attached to serial console
      https://github.com/ulli-kroll

      Kommentar


      • #4
        nach eurer Meinung "könnte" also die Variante 1 (Konverter) funktionieren?

        Weil wenn dem so ist geh ich sofort los und besorg 2 von den Dingern um das Knoppix arbeiten zu lassen.

        Sämtliche Threads die sich mit dem Wiederherstellen von Raid`s befassen, habe ich natürlich schon gelesen, jeddoch ist in keinem ein Problem mit einem Raid 0 gelöst worden. ist es dann die gleiche Prozedur oder ein gänzlich anderer Weg?

        mdadm ist mir ein Begriff, wenn ich auch kein Linux-Prof bin.

        mfg
        Monorail

        P.S.: Bei etwaigen Fragen weshalb ich Raid 0 wählte, bitte lesen: Link
        NAS:
        Product Name: IB-NAS4220-B
        Firmware Version: 2.6.3.IB.1.RS.1
        MlDonkey Version: 2.9.5 (derzeit nicht wegen Problemen)
        Userscript (derzeit nicht wegen Problemen)
        HDD: 2 x Seagate 500 GB Barracuda 7200.11 (derzeit im ****)
        Raid level: RAID 0 (schlechte Wahl wie ich feststellen musste)
        Mein Problem: THREAD
        Router:
        Product Name: Linksys WRV200 mit VPN
        Firmware Version: 1.0.39

        Kommentar


        • #5
          Hallo

          Der Weg ist, bis auf die Größe des Arrays identisch.
          Ich würde aber empfehlen nicht den automatischen Weg (Autorun beim Systemstart) zu nehmen. Sondern erst das Array mit dem mdadm Befehl zu untersuchen.

          z.B. USB und nur CD/DVD Lauftwerk (IDE/ATA)
          Code:
          mdadm --examine /dev/sda
          mdadm --examine /dev/sdb
          Wenn plausible Werte herauskommen, kann das Array mit
          Code:
          mdadm --assemble /dev/md0 /dev/sda1 /dev/sda1
          für die Systempartition
          und
          Code:
          mdadm --assemble /dev/md1 /dev/sda2 /dev/sdb2
          für die Datenpartition
          gestartet werden

          Sonst bitte einen neuen Thread aufmachen !

          E-mAn
          Some random kernel coder
          Lots of stuff attached to serial console
          https://github.com/ulli-kroll

          Kommentar


          • #6
            so.

            ich hab jetzt die 2 adapter und mach mich frisch fröhlich ans Werk.

            ich boote jetzt dann schnell mal ins Knoppix und editiere diesen Beitrag dann weiter.

            bis dann

            Monorail

            ---------------------------------------------
            angekündigter edit:

            knoppix mag mein notebook nicht. deshalb ubuntu 8.04 *g*.

            system bootet ohne probleme.
            beide Platten angesteckt, aber es wird nur eine erkannt (die platte die ich schon laienhaft als problemlos angesehen habe -> siehe screeshot1)
            andere Platte funktioniert nicht richtig. Sie macht periodisch wiederkehrende Geräusche als ob sie anlaufen wollte und es nicht schafft. -> Tipp aus anderem Thread [Link] bringt nichts. Ich glaube allerdings das ElektromAn eine andere Kraft meinte. ich trau mich nicht rüber auf eine Platte unter Spannung fester draufzuklopfen...

            allerdings:
            Zitat von Seagate.com zu genau meinen Platten ->
            2.8.5.1 Operating shock
            These drives comply with the performance levels specified in this document when subjected to a maximum
            operating shock of 63 Gs based on half-sine shock pulses of 2 msec. Shocks should not be repeated more
            than two times per second.
            2.8.5.2 Nonoperating shock
            The nonoperating shock level that the drive can experience without incurring physical damage or degradation
            in performance when subsequently put into operation is 300 Gs based on a nonrepetitive half-sine shock pulse
            of 2 msec duration.
            also sollten die eh einiges aushalten, oder?

            bitte um Tipps bzw. Korrekturen

            mfg
            Monorail
            Zuletzt geändert von Monorail; 29.09.2008, 21:36. Grund: angekündigter edit
            NAS:
            Product Name: IB-NAS4220-B
            Firmware Version: 2.6.3.IB.1.RS.1
            MlDonkey Version: 2.9.5 (derzeit nicht wegen Problemen)
            Userscript (derzeit nicht wegen Problemen)
            HDD: 2 x Seagate 500 GB Barracuda 7200.11 (derzeit im ****)
            Raid level: RAID 0 (schlechte Wahl wie ich feststellen musste)
            Mein Problem: THREAD
            Router:
            Product Name: Linksys WRV200 mit VPN
            Firmware Version: 1.0.39

            Kommentar


            • #7
              nach einigen Tests mehr, habe ich nun den Eindruck gewonnen das meine Platte(n) nicht mehr zu retten sind und ich sie bald zum Händler tragen kann. Die (defekte?) Platte springt nicht an, obwohl sie das bei einem Kumpel von mir beim austesten erst noch getan hat.

              Da kommt mir gerade ein Gedanke: Ist es theoretisch möglich, das eine Platte irgendeinen Fehler hat so das sie beim "anstarten" eine wesentlich höhere Spannungsspitze erzeugt als unter normalen Bedingungen? Weil das handelsübliche PC-Netzteil hat es ja "geschafft". meine Theorie ist das das kleine NAS-Netzteil (und jetzt das Netzteil des Adapters) nicht genügend Saft liefern und sie dadurch bei der Hälfte stehen bleibt und es immer wieder versucht. (damit erkläre ich mir die periodisch wiederkehrenden "Anstart"-Laute die die Platte von sich gibt.)

              Alles einfach nur noch verwirend...

              mfg
              Monorail
              Zuletzt geändert von Monorail; 30.09.2008, 20:09.
              NAS:
              Product Name: IB-NAS4220-B
              Firmware Version: 2.6.3.IB.1.RS.1
              MlDonkey Version: 2.9.5 (derzeit nicht wegen Problemen)
              Userscript (derzeit nicht wegen Problemen)
              HDD: 2 x Seagate 500 GB Barracuda 7200.11 (derzeit im ****)
              Raid level: RAID 0 (schlechte Wahl wie ich feststellen musste)
              Mein Problem: THREAD
              Router:
              Product Name: Linksys WRV200 mit VPN
              Firmware Version: 1.0.39

              Kommentar


              • #8
                Hallo

                Hmmm, nicht mal eine schlechte Idee. Also das mit dem Einschaltstrom hätte mir doch eigentlich früher einfallen sollen.

                Im technischen Bereich gibt es sowas wie ein Einschaltstrom. Und der ist leider nicht zu vernchlässigen. Bestes Beispiel sind Glühlampen. Bei 230 W an 230 V braucht diese nach Ohm 1 A. Beim Einschalten sind dies aber bis zu 10A. Beim PC und anderen Sachen ist das auch

                Und das mit der Kraft habe ich ehrlich gemeint. Das natürlich der Händler bei so einem Fall die Gewährleistung/Garantie verweigert ist normal. Nur wenn du jetzt die Platte einschickst und dann dir Firma sagt wir können die Daten retten wird es teuer. Die rechnen soweit ich weiß nach GByte ab.

                E-mAn
                Zuletzt geändert von ElektromAn; 30.09.2008, 20:21.
                Some random kernel coder
                Lots of stuff attached to serial console
                https://github.com/ulli-kroll

                Kommentar


                • #9
                  also ich hab schon fest geklopft und das waren sicherlich nicht 63G geschweige denn 300G. es rührt sich nichts. außer dem Geräusch das sich hartnäckig weiter hält gibt es nichts neues. Auch mit dem PC-Netzteil keine Änderung der Situation
                  (abgesehen davon das ich wieder schlauer geworden bin; 2 stunden gesucht welche kabel ich denn nun kurzschließen muss damit das **** Netzteil anspringt, jaja die schule ist auch schon eine weile her. *g*)

                  langsam weiß ich nicht mehr weiter. was glaubst du (ihr), würde der Händler die Platte zurücknehmen?

                  Kaufdatum Dez. 2007
                  Garantie: 1 Jahr
                  Seagate gibt ja glaub ich 5 Jahre. (?)

                  mfg
                  Monorail

                  mal so nebenbei: hab mir im internet aufgenommene Geräusche von Seagate Barracudas zu verschiedenen Defekten (Headcrash, defekter Spindelmotor, etc) angehört und keiner hört sich annähernd so an wie meine "einzigartige" Platte.
                  -> Bei Interesse zu diesem Phänomen kann ich ja mal eine "Jam-Session" mit meiner Platte machen und euch das Ergebniss zum besten geben. *g*
                  Zuletzt geändert von Monorail; 30.09.2008, 20:53.
                  NAS:
                  Product Name: IB-NAS4220-B
                  Firmware Version: 2.6.3.IB.1.RS.1
                  MlDonkey Version: 2.9.5 (derzeit nicht wegen Problemen)
                  Userscript (derzeit nicht wegen Problemen)
                  HDD: 2 x Seagate 500 GB Barracuda 7200.11 (derzeit im ****)
                  Raid level: RAID 0 (schlechte Wahl wie ich feststellen musste)
                  Mein Problem: THREAD
                  Router:
                  Product Name: Linksys WRV200 mit VPN
                  Firmware Version: 1.0.39

                  Kommentar


                  • #10
                    Wenn die Platte sich normal beim Starten meldet kann du mal alles Sektoren auf der Platte testen (auslesen)

                    Code:
                    dd if=/dev/sda of=/dev/null bs=1M
                    Alle Daten werden von der Platte in das Null-Device kopiert, es sollte keine Fehlermeldung aufkommen.

                    E-mAn
                    Some random kernel coder
                    Lots of stuff attached to serial console
                    https://github.com/ulli-kroll

                    Kommentar


                    • #11
                      das problem ist das die platte nicht bis zum "erkennen" durch egal welches os kommt. sondern, so wies scheint, beim "Plattenboot" stecken bleibt... die andere Raid platte funktioniert. sie wird erkannt. sowohl dd als auch mdadm funktionieren.

                      Monorail
                      NAS:
                      Product Name: IB-NAS4220-B
                      Firmware Version: 2.6.3.IB.1.RS.1
                      MlDonkey Version: 2.9.5 (derzeit nicht wegen Problemen)
                      Userscript (derzeit nicht wegen Problemen)
                      HDD: 2 x Seagate 500 GB Barracuda 7200.11 (derzeit im ****)
                      Raid level: RAID 0 (schlechte Wahl wie ich feststellen musste)
                      Mein Problem: THREAD
                      Router:
                      Product Name: Linksys WRV200 mit VPN
                      Firmware Version: 1.0.39

                      Kommentar


                      • #12
                        Dann Teste mal dies
                        http://seagate-de.custhelp.com/cgi-b...i=&p_topview=1
                        Seagate Plattentest, geht nur mit SATA oder IDE Interface kein USB !!.


                        E-mAn
                        Some random kernel coder
                        Lots of stuff attached to serial console
                        https://github.com/ulli-kroll

                        Kommentar


                        • #13
                          danke für den tipp. hab das tool unter windows schon probiert. allerdings ohne erfolg. unter dos mach ich das morgen.

                          gute nacht.

                          Monorail
                          NAS:
                          Product Name: IB-NAS4220-B
                          Firmware Version: 2.6.3.IB.1.RS.1
                          MlDonkey Version: 2.9.5 (derzeit nicht wegen Problemen)
                          Userscript (derzeit nicht wegen Problemen)
                          HDD: 2 x Seagate 500 GB Barracuda 7200.11 (derzeit im ****)
                          Raid level: RAID 0 (schlechte Wahl wie ich feststellen musste)
                          Mein Problem: THREAD
                          Router:
                          Product Name: Linksys WRV200 mit VPN
                          Firmware Version: 1.0.39

                          Kommentar

                          Lädt...
                          X