yobit eobot

Ankündigung

Einklappen
Keine Ankündigung bisher.

CPU Auslastung auslesen

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • IB-NAS4220-B CPU Auslastung auslesen

    Mal ne kurze Frage.
    Ich des öfteren in diversen Beiträgen darüber gestolpert, dass die CPU las der Box ausgelesen wurde.
    Aber wie das gemacht wurde, steht nirgends.
    Ich kenne nur den Befehl "top", aber den gibt es in der Box nicht.

    Wie kann ich mir also die Auslastung des Prozessors ansehen?
    NAS: IB-NAS4220-B
    Ver.: 2.6.3.IB1.RS.1
    HDD: 2x500GB Seagate ST3500320AS, Raid1, ext3
    LAN: Fritz!Box Fon WLAN
    Conceptronic 8-Port FastEthernet Switch

  • #2
    Ganz kurze Antwort

    Code:
    IB-NAS4200-B> w
     03:29:28 up 14033 days, 19:29,  1 user,  load average: 0.02, 0.19, 0.15
    USER     TTY        LOGIN@   IDLE   JCPU   PCPU WHAT
    root     ttyp0     03:26    0.00s  0.11s  0.06s w
    HTH

    Kommentar


    • #3
      38 Jahre up, das ist absoluter Rekord.
      Ich wusste nicht, dass es die Box schon so lange gibt ;-)

      Die restlichen Angaben dürften genauso vertrauenswürdig sein.

      Gruß
      Gerhard
      NAS1: IB-NAS2000, Rev. B (verkauft)
      HDD: 1x500GB Seagate ST3500630A
      NAS2: IB-NAS4220-B, Board Rev. V1.2
      HDD: 2x500GB Seagate ST3500630AS, Raid1, ext3
      FW: 2.6.3.2
      NAS3: IB-NAS4220-B, Board Rev. V1.2
      HDD: 2x160GB Seagate ST3160815AS, Raid1, ext3
      FW: 2.6.3.2
      NAS4: Synology DS209+
      HDD: 2x1TB Seagate ST31000340AS, HDD-FW: SD1A, Raid1, ext3
      FW: DSM 4.0-2219 (Final)
      NAS5: Synology DS212+
      HDD: 2x3TB WD30EZRX, Raid1, ext4
      FW: DSM 4.0-2219 (Final)
      LAN:
      2 x TP-Link 8Port Gigabitswitch TL-SG1008D

      Kommentar


      • #4
        @ Tee_im_s: Wo hast du den Befehl her? In meiner Box (Local_Apps installiert) gibt's den nicht.
        mfg,
        vishcompany

        Newbie-FAQ - Linux für Anfänger - forumregeln - Leitfaden
        for our international users: language settings - posting guide - translation service

        Verwechsle niemals Redundanz (RAID1) mit Datensicherheit (backup)!

        Bitte keine supportanfragen per PM. Support gehört ins Forum, dann haben alle etwas davon!

        Kommentar


        • #5
          Hallo vishcompany,

          ich hab hier ein Paket unter /mnt/md1/public/applications/procps (weiss nicht mehr woher, vermutlich hier aus dem Forum), da ist "w" aber auch "top" u.a. mit drin.

          Gruß
          Gerhard
          NAS1: IB-NAS2000, Rev. B (verkauft)
          HDD: 1x500GB Seagate ST3500630A
          NAS2: IB-NAS4220-B, Board Rev. V1.2
          HDD: 2x500GB Seagate ST3500630AS, Raid1, ext3
          FW: 2.6.3.2
          NAS3: IB-NAS4220-B, Board Rev. V1.2
          HDD: 2x160GB Seagate ST3160815AS, Raid1, ext3
          FW: 2.6.3.2
          NAS4: Synology DS209+
          HDD: 2x1TB Seagate ST31000340AS, HDD-FW: SD1A, Raid1, ext3
          FW: DSM 4.0-2219 (Final)
          NAS5: Synology DS212+
          HDD: 2x3TB WD30EZRX, Raid1, ext4
          FW: DSM 4.0-2219 (Final)
          LAN:
          2 x TP-Link 8Port Gigabitswitch TL-SG1008D

          Kommentar


          • #6
            merci, mir scheint, ich muss mal meine apps aktualisieren... top hab ich schon einige mal ziemlich vermisst.
            mfg,
            vishcompany

            Newbie-FAQ - Linux für Anfänger - forumregeln - Leitfaden
            for our international users: language settings - posting guide - translation service

            Verwechsle niemals Redundanz (RAID1) mit Datensicherheit (backup)!

            Bitte keine supportanfragen per PM. Support gehört ins Forum, dann haben alle etwas davon!

            Kommentar


            • #7
              Ohne top/w geht's übrigens auch, nämlich mit
              cat /proc/loadavg

              Grüße,
              chris

              Kommentar


              • #8
                [quote=gmeyer;13604]ich hab hier ein Paket unter /mnt/md1/public/applications/procps (weiss nicht mehr woher, vermutlich hier aus dem Forum), da ist "w" aber auch "top" u.a. mit drin.
                /quote]

                Guter Tip. Hab mal nach "procps" gesucht und das entsprechende Thema gefunden (siehe hier).

                Interressant ist auch das Thema "NAS erweitern durch Kernel Module".

                So lernt man auch Linux
                NAS: IB-NAS4220-B
                Ver.: 2.6.3.IB1.RS.1
                HDD: 2x500GB Seagate ST3500320AS, Raid1, ext3
                LAN: Fritz!Box Fon WLAN
                Conceptronic 8-Port FastEthernet Switch

                Kommentar


                • #9
                  Hallo,
                  das 'w' nicht mit in busybox und somit vorinstalliert war ist mir leider entgangen - sorry fuer die Verwirrung.

                  Das Problem mit der uptime ist ja auch in dem procps thread
                  schonmal angesprochen worden, aber load, user, etc. stimmt(e) ja.
                  Ich glaub' ich muss mein procps auch nochmal updaten.

                  Gruss
                  Tee-im-S

                  Kommentar


                  • #10
                    Ich glaub' ich muss mein procps auch nochmal updaten.

                    Gut wäre es weil mit uptime bekommt man auch von
                    Code:
                     up 14154 days,  6:49
                    Was ja schon mehr als 38 Jahre sind wow.
                    Der Befehl kommt ja aus dem procps Packages.
                    Kein Support per PN! Bitte nutzt das Forum hier oder schaut bitte in Wiki rein!

                    Kommentar


                    • #11
                      Diese Uptime Geschichte scheint wohl immer so zu sein. Hab bei mir die letzte für ARM stable gekenzeichnet procps installiert die es für Gentoo gibt. Die Uptime ist trotzdem nicht "echt"

                      Kommentar


                      • #12
                        Ich habe mal was geändert an Packages und Linuxsystem/Kernel

                        Jetzt sieht's so bei mir aus:

                        Code:
                        root@Home-Server ~ $ w
                         16:59:22 up 42 days,  4:48,  1 user,  load average: 0.41, 0.21, 0.12
                        USER     TTY        LOGIN@   IDLE   JCPU   PCPU WHAT
                        root     ttyp0     16:59    0.00s  0.14s  0.07s w
                        root@Home-Server ~ $ uptime
                         17:00:16 up 42 days,  4:49,  1 user,  load average: 0.32, 0.23, 0.13
                        Das sieht jetzt eigendlich ganz gut aus da meine Box schon 42 Tage on ist

                        Was sagt denn jetzt unmae -a

                        Code:
                        root@Home-Server ~ $ uname -a
                        Linux Home-Server 2.6.22 #150 Sun Feb 25 4:16:31 CST 2008 armv4l9 etch unknown
                        Das sieht auch ganz gut aus.
                        Kein Support per PN! Bitte nutzt das Forum hier oder schaut bitte in Wiki rein!

                        Kommentar


                        • #13
                          Hallo speedport701

                          was hast du geändert ?

                          Das Kommando "uptime" etc. wertet wohl auch nur die beiden Zahlen aus, die in /proc/uptime in Kernel stehen ("cat /proc/uptime", liefert wahrscheinlich Sekunden seit ?).

                          Gruß
                          Gerhard
                          NAS1: IB-NAS2000, Rev. B (verkauft)
                          HDD: 1x500GB Seagate ST3500630A
                          NAS2: IB-NAS4220-B, Board Rev. V1.2
                          HDD: 2x500GB Seagate ST3500630AS, Raid1, ext3
                          FW: 2.6.3.2
                          NAS3: IB-NAS4220-B, Board Rev. V1.2
                          HDD: 2x160GB Seagate ST3160815AS, Raid1, ext3
                          FW: 2.6.3.2
                          NAS4: Synology DS209+
                          HDD: 2x1TB Seagate ST31000340AS, HDD-FW: SD1A, Raid1, ext3
                          FW: DSM 4.0-2219 (Final)
                          NAS5: Synology DS212+
                          HDD: 2x3TB WD30EZRX, Raid1, ext4
                          FW: DSM 4.0-2219 (Final)
                          LAN:
                          2 x TP-Link 8Port Gigabitswitch TL-SG1008D

                          Kommentar


                          • #14
                            Wo hast du den 2.6.22 Kernel her? Der is doch wohl net nativ geladen?!

                            Kommentar


                            • #15
                              Zitat von gmeyer
                              Das Kommando "uptime" etc. wertet wohl auch nur die beiden Zahlen aus, die in /proc/uptime in Kernel stehen ("cat /proc/uptime", liefert wahrscheinlich Sekunden seit ?).

                              Ich habe die Befehle und Bin von der Box mit mein Debian /chroot getauscht
                              Wenn ich so sehe dann gibt cat /proc/uptime den Wert aus=1172760364.77 1678707.84 was damit gemeint ist sind Sekunden... Diese scheinen bissen viel zu sein!? Bei w oder uptime sieht der Wert so aus=2:58:36 up 43 days, 14:47, 1 user, load average: 0.07, 0.15, 0.11
                              USER TTY LOGIN@ IDLE JCPU PCPU WHAT
                              root ttyp0 02:56 0.00s 0.14s 0.07s w
                              und
                              02:59:04 up 43 days, 14:47, 1 user, load average: 0.05, 0.13, 0.10

                              nun die Version gibt (uptiime -V) = procps version 3.3.9 aus.

                              Zitat von hypfvieh
                              Wo hast du den 2.6.22 Kernel her? Der is doch wohl net nativ geladen?!
                              Denn Kernel habe ich von jemanden bekommen der viele mit solchen Sachen macht. Neinen ist er nicht aber es sollte auch möglich sein den Kernel in die Firmware von RS gegen den alten Kernel zu tauschen. Ich brauche noch bissen Zeit wenn ich die Sourcen von RS durch habe.
                              Kein Support per PN! Bitte nutzt das Forum hier oder schaut bitte in Wiki rein!

                              Kommentar

                              Lädt...
                              X