Ankündigung

Einklappen
Keine Ankündigung bisher.

Hilfe bei IP Vergabe / Netzwerkintegration eines ASUSTOR NAS

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Hilfe bei IP Vergabe / Netzwerkintegration eines ASUSTOR NAS

    Hallo zusammen,

    ich habe ein Problem mit meinem ASUSTOR 5004. Weniger mit dem Gerät, als mit der Anbindung ins LAN und der Vergabe der richtigen IPs damit alles funzt.
    Angeschlossen ist der ASUSTOR an einem Switch, woran ebenfalls mein Desktop-PC hängt sowie die Verbindung zum Router. Internet am PC läuft aber es kann keine Verbindung zum NAS aufgebaut werden. Folge ich dem Troubleshooting im ASUSTOR Handbuch, passe ich die IP meines Computers an die IP des ASUSTOR an - dann funktionierts. Mit dem Knackpunkt dass ich dann nicht mehr ins Internet komme.

    Habe mich gerade mal in meinen Router (TP Link TL-WR841N) eingeloggt und sehe dass der ASUSTOR unter der IP 192.168.0.103 gefunden wird, im ASUSTOR Controlcenter am Rechner wird es ebenfalls gefunden, allerdings unter der IP 192.168.1.115. Mein PC hat die IP 192.168.0.108. Mein Netzwerk hat die IP 192.168.0.1.
    Jetzt fällt natürlich sogar mir als Laien auf dass das Netzwerk und der Rechner eine andere IP hat wie mein NAS. Ich habe aber keine Möglichkeit auf den NAS zuzugreifen um die IP zu ändern.
    Die IP vom Netzwerk und vom Rechner habe ich bereits angepasst auf 192.168.0.1, mit dem Resultat dass dann entweder nur noch der Zugiff zum NAS oder garnix mehr geht :(

    Was mache ich falsch??! Wie krieg ich das hin??!

    PS.: Zur Info falls es was zur Sache tut, ist ein Windows 7 Rechner.

    Vielen Dank für eure Hilfe im Voraus!
    Markus
    Zuletzt geändert von Mackes; 01.03.2017, 16:42.

  • #2
    Hi Markus,

    Netzwerkgrundlagen ... ...

    Die Netzmaske sagt wie groß das Netz ist.
    255.255.255.0 sagt das die ersten 24 Bit der Adresse das Netz darstellen.
    Bei 255.255.255.192 würden die ersten 26 Bit das Netz darstellen.
    Die Adresse ist genau so wie die Maske eine 32Bit Binärzahl. Nur für den Menschen in 4 Byte geschrieben.
    Es müssen also alle Adressen der Geräte an deinem Switch in EINEM Netz sein.
    Bei einer Maske wie 255.255.255.0 wären das die Adressen 192.168.0.1 bis 192.168.0.254.
    Es können aber auch die Adressen 192.168.1.1 bis 192.168.1.254 sein. Aber nicht beide!!
    Entweder das Netz 192.168.0.x ODER 192.168.1.x
    Wenn dein NAS sich also im Moment nicht auf 192.168.0.irgendwas umstellen läßt,
    dann nimmst du für den Router und den PC einfach 192.168.1. als Netz.
    Dann sollten alle drei mit einander reden können.

    Das war jetzt mal so in Kürze und schnell errzählt

    Gruß
    Dino

    Kommentar


    • #3
      Hey Dino,
      danke für deine Lehrstunde in Netzwerkgrundlagen :-)

      Dass der IP Raum identisch seien sollte leuchtet mir ein, aber das mit der Netzmaske schnall ich nicht. Habe jetzt gerade als erstes am Router von 192.168.0.1 auf 1.1 geändert, und anschliessend die IP vom Rechner angepasst. Dabei bekomme ich die Meldung dass die netzmaske nicht korrekt sei bzw IP-Konflikt. Welche Maske wäre bei ip 192.168.1.1 denn dann richtig?

      Kommentar


      • #4
        Hallo,

        Zitat von Mackes Beitrag anzeigen
        Hey Dino,
        danke für deine Lehrstunde in Netzwerkgrundlagen :-)

        Dass der IP Raum identisch seien sollte leuchtet mir ein, aber das mit der Netzmaske schnall ich nicht. Habe jetzt gerade als erstes am Router von 192.168.0.1 auf 1.1 geändert, und anschliessend die IP vom Rechner angepasst. Dabei bekomme ich die Meldung dass die netzmaske nicht korrekt sei bzw IP-Konflikt. Welche Maske wäre bei ip 192.168.1.1 denn dann richtig?
        mit einem anderen "Vergleich" ausgedrückt ... Das Netz ist dein Ortsname, die Netzmaske ist die maximal mögliche Einwohnerzahl des Ortes.

        Machen wir es mal Binär ...

        11000000 10101000 00000001 00000001 binär = 192.168.1.1 dezimal (IP-Adresse)
        11111111 11111111 11111111 00000000 binär = 255.255.255.0 dezimal (Netzmaske)

        Alles Bits die bei der Netzmaske auf "1" stehen sagen aus das die entsprechenden Bits der IP-Adresse an diesen Stellen das Netz (den Ortsnamen) identifizieren.
        Alle Bits die bei der Netzmaske auf "0" stehen zeigen dir den "Hostbereich" und identifizieren den Endgerätebereich (die "Einwohner" deines Ortes).

        Du kannst also in dem Fall deinen Geräten IP-Adressen von ...
        11000000 10101000 00000001 00000001 = 192.168.1.1
        ... bis ...
        11000000 10101000 00000001 11111110 = 192.168.1.254
        ... geben.

        11000000 10101000 00000001 00000000 = 192.168.1.0 (alle Host-Bits auf "0") identifizert das Netz an sich. (der Ortsname)
        ... und ...
        11000000 10101000 00000001 11111111 = 192.168.1.255 (alle Host-Bits auf "1") ergibt die Broadcast-Adresse (Rundruf an alle Geräte)

        Nimm dir nen Taschenrechner oder Windows-Calc und stell ihn auf Logik- oder Programmierermodus. Dann kannst du mal ein wenig mit Dezimal und Binär rumspielen.

        Wenn dein Router zB 192.168.1.1 hat und dein NAS 192.168.1.115, dann muß dein PC auch im selben Netz sein. Also zB 192.168-1.20 oder sowas.
        Jede IP-Adresse darf nur EINMAL vorhanden sein. Sonst bekommst du die Meldung "Duplicate IP". Im Ort haben ja auch nicht alle die selbe Hausnummer.

        Die Netzmaske muß in allen Geräten IDENTISCH sein. Da ja alle Geräte im selben Ort leben. Der ist ja nicht für den einen größer und für den anderen kleiner.
        Also bei allen Geräten 255.255.255.0 eingeben.

        Das Default-Gateway (die Autobahnauffahrt) ist bei allen Geräten die IP-Adresse des Routers. Also in dem Fall bei ALLEN (!!bis auf den Router selber) die 192.168.1.1 .
        Der Router ist für alle Geräte der "Ausgang" ins Internet (also die Autobahnauffahrt zu anderen Orten).

        Gruß
        Dino
        Zuletzt geändert von dino03; 02.03.2017, 22:43.

        Kommentar


        • #5
          Hey Dino,
          danke für deine unglaublich ausführliche Antwort und SORRY für meine unverschämt späte Antwort! Asche auf mein Haupt!
          die gute Nachricht ist, dass das alles inzwischen so funktioniert wie es soll. Die schlechte Nachricht ist, dass ich keine Ahnung habe warum und das ganze Prinzip immer noch nicht verstanden habe

          jedenfalls ist ist jetzt alles verbunden in dem selben Netzwerk. Und tadaaaa: direkt das nächste Problem. Wenn ich jetzt zB mit dem iPhone über die App aifoto aus demselben Netzwerk auf das NAS zugreifen möchte, werde ich gebeten am NAS den EZ Router zu aktivieren. Mache ich dies erhalte ich die Nachricht: "mehrere Router erkannt. Die ip des routers weicht von der des nas ab"

          die ip vom nas ist 192.168.1.115 (subnet Maske 255.255.255.0), der Router hat 192.168.1.1. Was passt daran nicht.....?!

          edit: habe gerade nochmal in den routereinstellungen geschaut. Die LAN ip des routers ist 192.168.1.1., die wan ip ist 192.168.254.100 und dynamisch zugewiesen worden. Ändere ich auf static ip stehe ich wieder vor dem Problem das ich das Prinzip nur so halb schnalle....
          Zuletzt geändert von Mackes; 16.03.2017, 19:14.

          Kommentar


          • #6
            Mal ne Frage von mir ...
            Welcher Provider ??
            ggf. noch anderes Equipment außer dem TP-Link ggf, davor ?

            Willst du mit dem alfoto Tool auf die Daten von deinem NAS zugreifen ???
            EZ Router und alfoto sind ein Asus "Erfindung" wie ich es auf die schnelle suchen konnte, Richtig ??
            Some random kernel coder
            Lots of stuff attached to serial console

            Kommentar


            • #7
              So war mein Plan mit aifoto. Klar kann ich auch via ip auf das nas zugreifen, möchte aber eine Oberfläche/Anwendung mit der ich mir die Bilder schneller anschauen kann. Ähnlich wie bei Dropbox. Per Browser ist das sehr sperrig finde ich.

              Genau, das nas ist ein asustor. Mein Provider ist versatel 1&1.
              zwischen dem nas und dem Router hängt sonst nur noch ein Switch.
              Zuletzt geändert von Mackes; 16.03.2017, 19:44.

              Kommentar


              • #8
                Zitat von Mackes Beitrag anzeigen
                So war mein Plan mit aifoto. Klar kann ich auch via ip auf das nas zugreifen, möchte aber eine Oberfläche/Anwendung mit der ich mir die Bilder schneller anschauen kann. Ähnlich wie bei Dropbox. Per Browser ist das sehr sperrig finde ich.
                Aber du willst mit dem Tool auf deine Bilder vom NAS drauf,
                Ob das jetzt von "zu hause" oder unterwegs ist ?
                Und im Tool werden Username/Passwort eingetragen.

                Tschuldigung das ich das Frage, ich sehe da vielleicht ein paar Probleme, die Dino (vielleicht) noch nicht gesehen hat.
                Deine IP Adressen und Fehlermeldung ist komisch ...
                Zitat von Mackes Beitrag anzeigen
                Genau, das nas ist ein asustor. Mein Provider ist versatel 1&1.
                zwischen dem nas und dem Router hängt sonst nur noch ein Switch.
                OK.
                Der Router ist schon etwas alt aber egal und "vor" dem Router ist erst mal nichts.
                Wie sieht es mit der Routereinstellung aus ?
                Du sagtest WAN IP 192.168.254.100 ??
                Es kann auch auch hinten 1-255 stehen.

                Betriebssystem Windows ??
                Nein ist nicht wichtig, ggf, kann du einen Befehl/Tool ausführen und mir das Ergebnis per private Mail zukommen lassen?

                Noch ein Erklärung zu Netzmaske und Co.
                Nimm mal an alle Tel. Vorwahlen haben die gleiche Stellenanzahl z.B. 5
                und deine Ortsnummer (oder wie das DING früher hieß) hat auch fünf Stellen.

                Du musst zwar jetzt für jeden Teilnehmer immer die vollständige Telefonnummer währen, aber die ersten 5 Stellen geben die Entscheidung ob Fern- oder Ortsgespräch.

                Im einfachsten Fall müssen alle deine Geräte sich im selben Ortsnetz befinden, wenn ein Gerät eine andere Vorwahl hat wird im Router die Entscheidung getroffen das Gespräch nach draußen zu vermitteln. Dein Router ist quasi deine "Ortsvermittlung"

                Ob die Zahlen jetzt von 0-9 oder 0-1 gehen ist erst mal egal.

                Für Anfänger ist es meistens Nervig da Fehler zu suchen ...

                Schau mal hier, die "Sendung mit der Maus" erklärt das Internet
                https://www.youtube.com/watch?v=8PNRrOGJqUI
                Some random kernel coder
                Lots of stuff attached to serial console

                Kommentar


                • #9
                  Ich möchte mit der App von zuhause drauf zugreifen. Einen externen Zugang möchte ich nach Möglichkeit garnicht erst ermöglichen, da ich das nas als Datensicherung nutze (bin Fotograf). Ein Zugang aus dem selben Netzwerk würde mir genügen.
                  Neben den Nas-Anmeldedaten muss ich in der App die ip angeben.

                  was meinst du genau mit "wie siehts mit der routereinstellung aus?"? Soll ich eine Alternative ip versuchen?
                  der verdaten-Router ist erst ein paar Wochen alt, der andere (der Vorgänger) hat nach 11 Jahren den Dienst quittiert.

                  Betriebssystem ist Windows 7. welchen Befehl soll ich ausführen? Welche Infos benötigst du?

                  schöne Grüße und schonmal vielen Dank im Voraus für deine Bemühungen!
                  mackes

                  Kommentar


                  • #10
                    Die EZ Router Tool, will dir ein Loch in deine Firewall bohren, damit du von draußen per App auf dein NAS kannst. Nur ist es vom Provider NAT etwas aufgehalten worden.
                    -> Fehlermeldung IP 192.168.254.100

                    In der Anleitung steht was von
                    Connect via Host/IP, verbinden mit Host/IP oder
                    Auto Discovery, automatisch erkennen.

                    Versuche mal den letzten Fall, Username/Passwort bitte von deiner NAS App nehmen.

                    Wenn das nicht geht müssen wir das per Host/IP versuchen.

                    Die App ist, so wie ich es lesen kann, primär dafür ausgelegt von Au0en zuzugreifen.
                    wurde aber von dem Provider NAT behindert. Diese NAT wird benutzt damit du eine IPv4 Adresse bekommst. Im Normalfall ist es OK, da du ja meistens Datenverbindung ins Internet aufbaust.
                    Stelle dir das quasi wie eine Chefsekretärin, die immer durch vermittelt. Dieser kann zwar telefonieren, aber alles andere blockt diese ab.
                    Aus dem Grunde wollte ich das mit dem Windowsbefehl, der aber jetzt nicht mehr benötigt wird.
                    Some random kernel coder
                    Lots of stuff attached to serial console

                    Kommentar


                    • #11
                      Das hatte ich bereits durchprobiert. Auto-Detect führt zu dem Ergebnis "kein Server gefunden" und anmelden via Ip führt zu der Meldung "bitte ez Router am nas aktivieren".
                      ich muss wie gesagt grundsätzlich wohl erst am Server die Möglichkeit zulassen von außen zugreifen zu können. Und das führt widerrum wieder zu der Meldung "mehrere Router gefunden, Netzwerkumgebung überprüfen"...... ein Teufelskreis ����

                      Kommentar


                      • #12
                        Zitat von Mackes Beitrag anzeigen
                        Das hatte ich bereits durchprobiert. Auto-Detect führt zu dem Ergebnis "kein Server gefunden" und anmelden via Ip führt zu der Meldung "bitte ez Router am nas aktivieren".
                        Was ist das denn für ein Q****

                        Zitat von Mackes Beitrag anzeigen
                        ich muss wie gesagt grundsätzlich wohl erst am Server die Möglichkeit zulassen von außen zugreifen zu können. Und das führt widerrum wieder zu der Meldung "mehrere Router gefunden, Netzwerkumgebung überprüfen"...... ein Teufelskreis 😩😉
                        Kannst du die Meldung "überspringen" ??
                        Kann ja sein das sich hinter ez Router noch ein Bonjour/Zeroconfig/Avahi Dienst verbirgt, der irgendwelche anderen Dienste bekannt macht .

                        Und das mit den mehreren Routern kommt von deinem Provider der eben das Carrier Grade NAT benutzt um dir eine "interne" IP zu vergeben. Die ist logischerweise nicht von außen erreichbar da der Provider diese UPnP nicht macht. Würde auch nicht viel bringen, da doppeltes NAT (deins und vom Provider) nicht einfach ist.

                        muss mal überlegen ...
                        Some random kernel coder
                        Lots of stuff attached to serial console

                        Kommentar


                        • #13
                          So habe jetzt auch mal noch ein bisschen herumgetüftelt und gesucht, und den Fehler glaube ich gefunden. Es scheint an der App aifoto zu liegen.
                          asustor bietet zwei weitere Apps an (AiData und aimusic), und siehe da, mit diesen beiden Apps geht es problemlos, und ohne weitere EZ-Routereinstellungen am NAS. Einfach auf Auto-Detect, Benutzernamen und Passwort vom Nas rein und los geht's.
                          danke vielmals für eure Bemühungen!

                          Kommentar


                          • #14
                            Zitat von Mackes Beitrag anzeigen
                            So habe jetzt auch mal noch ein bisschen herumgetüftelt und gesucht, und den Fehler glaube ich gefunden. Es scheint an der App aifoto zu liegen.
                            asustor bietet zwei weitere Apps an (AiData und aimusic), und siehe da, mit diesen beiden Apps
                            geht es mit book of ra gratis problemlos, und ohne weitere EZ-Routereinstellungen am NAS. Einfach auf Auto-Detect, Benutzernamen und Passwort vom Nas rein und los geht's.
                            danke vielmals für eure Bemühungen!
                            Und ich danke für Deine Erfahrung, die mein Problem zu lösen holf ^^
                            Grüße,
                            mitchel

                            Kommentar


                            • #15
                              Freut mich geholfen zu haben 😀👍

                              Kommentar

                              Lädt...
                              X