Ankündigung

Einklappen
Keine Ankündigung bisher.

Acer H340 + Debian: WOL?

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Acer H340 + Debian: WOL?

    Hallo alle zusammen...

    Ich habe mir vor kurzem ein Acer easystore H340 zugelegt und bin eigentlich sehr begeistert von dem Gerät.
    Da ich ihn als Server (Datei-, SQL-, SVN- und Media-Server) benutzen möchte, habe ich mir Debian (Lenny) drauf gemacht (Dank diesen Forums hab ich das hinbekommen!!! ). Software läuft an sich auch problemlos.
    Jetzt dachte ich mir, dass WOL (Wake on Lan) sehr nützich wäre, doch leider hat bis jetzt kein Tutorial geholfen.

    Im BIOS gibt es dafür keine Option, da es jedoch unter Windows auch funktioniert, müsste es ja irgendwie gehen... ^^
    Ein Script hab ich mir auch geschrieben, sodass bei jedem Start 'ethtool -s eth0 wol g' aufgerufen wird und so WOL aktiviert wird. Das funktioniert auch wunderbar.
    Das 'halt'-Script habe ich auch modifiziert, sodass die Netzwerkkarte beim runterfahren theoretisch nicht ausgeschalten wird (NETDOWN=no).

    Wenn ich jedoch den Server runterfahre schaltet sich die Netzwerkkarte dennoch aus (zumindest sind beide LEDs aus) und wieder aufwecken lässt er sich natürlich auch nicht.

    Hat jemand eine Idee, wie man dieses Feature doch noch zum laufen bringen könnte?
    Hab ich vielleicht irgendwas übersehen?
    Vielen Dank im vorraus!!! ^^

    mfg
    hackmars

    installierte Software:
    -Debian Lenny
    -SSH, Samba
    -Apache2, MySQL-Server, Subversion, Mediatomb

    Hardware:
    -Acer easystore H340
    -onboard Netzwerkkarte (lspci: 09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8071 PCI-E Gigabit Ethernet Controller (rev 16) )
    Zuletzt geändert von hackmars; 08.10.2009, 21:19.

  • #2
    Hallo,

    hab es jetzt noch auf einem anderen PC ausprobiert, da hat funktioniert. Also ist die Vorgehensweise anscheinend korrekt. Bei dem 2. PC gab es jedoch einen Eintrag im BIOS. Da Wake-on-LAN beim Acer H340 unter Windows jedoch funktioniert, denke ich, dass es an den Einstellungen im Betriebssystem liegen müsste, da hier vor allem auch ein BIOS-Eintrag fehlt.

    Hat wirklich keiner eine Idee, woran es vielleicht liegen könnte?

    mfg
    hackmars

    Kommentar


    • #3
      So, jetzt hab ich das ganze mal mit Windows auf'm Acer H340 versucht, und das funktioniert. Wenn man also den Server mit Windows startet und wieder herunterfährt funktioniert WoL. Wenn als letztes Linux lief, funktioniert es nicht. Es muss also am Verhalten des Betriebssystems beim herunterfahren liegen.
      Weiß vielleicht jemand, welche Einstellungen Windows am Ende setzt, bzw. welche Linux nicht setzt? Schaltet Linux die Netzwerkkarte vielleicht irgendwo anders noch aus, als nur in '/etc/init.d/halt' (dort ist 'NETDOWN=no' gesetzt)?

      mfg
      hackmars

      Kommentar


      • #4
        hallo leute

        hab das mit dem wake on lan auch ausprobieren wollen funtioniert aber nicht so wie das sollte, weil unter windows muss man ins ruhemodus fahren oder man benutzt son blödes prog wo das ding automatisch an und ausgeht je nach einstellungen.

        hab auch unter linux laufen fürs raid und ich empfehle jedem linux (openfiler) drauf zu schmeissen 1. ist ein web linux 2. mehr einstellmöglichkeiten 3. software raid

        Kommentar


        • #5
          Hi,

          ich weiß das Thema ist schon ein Jahr alt, aber ich habe auch einen
          H340 mit Ubuntu Server 10.04 am laufen…

          Gibt es zu WOL oder zum Suspend irgendwas neues?
          Bekomme weder das eine noch das andere zum laufen!

          Die Netzwerkkarte (Marvell Yukon 88E8071) unterstützt WOL offensichtlich:
          Code:
          ethtool eth0
          
          …
          	Supports Wake-on: pg
          	Wake-on: g
          …
          Funktioniert WOL bei WHS nur, wenn man diesen über LightsOut in den
          Ruhemodus schickt, oder wenn man ihn auch herunterfährt?

          Grüße
          Alex

          Kommentar


          • #6
            gibt es hier mittlerweile eine Lösung? Habe auf dem H340 Nas4Free drauf und WOL geht nicht

            Kommentar

            Lädt...
            X